Problems accessing an online resource

Answered By: Fiona Paterson
Last Updated: 13 Jun 2024 Views: 21

If you can’t access on online resource, try these quick tips:

  1. If you get an error message, clear your cache and cookies, restart your browser and try again. This is especially important if you’ve recently changed your password.
  2. Try using a different browser. For example, if you are using Safari, try using Firefox or Chrome.
  3. Access resources via the Library website rather than the publisher’s platform. We advise to access online resources via CityLibrary SearchJournals A-Z, Databases A-Z or links in your Reading List Online.
  4. Search for an answer on Ask Us. Some resources require additional steps to access them, and you can find instructions by searching Ask Us.
  5. Is the database down? Check our Systems Status page to see if we have already reported an issue with a certain platform or publisher. If so, we might have published a workaround.
  6. Are you a short course student, other external member or have an alumni card? You might not have access our online resources remotely, but you can see our databases available via walk-in access.

Still having an issue?

If the suggestions above haven’t solved your issue, please contact the Library’s E-access team directly at e-access@city.ac.uk. When contacting us, please include:

  • The title or name of the resource you can’t access.
  • Your student registration number or City username.

If you are able to, please also include:

  • A screenshot of the whole browser page with the error message, including the link in the address bar.
  • Any trouble-shooting steps you have tried.

Search Ask Us

chat